Resta de darkframe a Toucam

Avatar de Usuario
mack
Mensajes: 1299
Registrado: 12 Mar 2006, 00:00
Ubicación: Almería Levante
Contactar:

Resta de darkframe a Toucam

Mensajepor mack » 15 Sep 2007, 11:19

Últimamente, como proceso del aprendizaje de la captura y procesado de imágenes planetarias, alentado por los consejos de Gab9555, me he propuesto aplicarle la resta de un masterdark también a los frames que componen un video, pese a su corta exposición, con el objeto de eliminar no ya su ruído térmico (despreciable para esta exposición) sino el bias y los hot pixels entre otras lindezas. Como bien sabemos el Registax ofrece esta posibilidad.

Pues bien, como los resultados con Júpiter no me parecieron nada agradables a la vista, me dispongo a grabar esta mañana un video de 120 segs. a 10fps de un objeto estático a ver qué pasa, aplicándole a la captura 1/25 de exposición y ganancia a tope (para apreciar mejor el resultado) y el resto de valores como gamma, etc. a la mitad. El resultado es éste:

Imagen

Como se puede apreciar la imagen tiene un tinte azulón un montón de rayas verticales. Ahora inmediatamente después tapo con la mano el objetivo de modo que la imagen quede oscura incluso a esa ganancia y tomo otro video de idéntica duración, resultando tras crear el Masterdark con Registax 4 la siguiente imagen:

Imagen

Bueno, al cargar este Masterdark en Registax 4 y marcar la pestaña "Dark Frame", en teoría lo que haría sería restar dicho Masterdark de cada frame individual del video que se cargue a continuación durante el proceso de apilado. Así lo hago, esperando encontrarme con una imagen limpia, pero:

Imagen

Vale, se ha oscurecido el fondo. Es obvio que el tono azulón le ha desaparecido durante la resta, pero eso también lo puedo hacer yo mediante otros métodos. Lo que me interesaba es que desaparecieran las rayas, pues no permiten casi tocar los wavelets sin que la imagen se torne horrible y sin embargo ahí siguen.... Se supone que en 1200 imágenes la aleatoriedad ha de ser suficiente como para que borre estos defectos cosméticos. Ya finalmente, la porquería más grande entre las grandes cuando le aplico un poco, sólo un poco de wavelets de grado 4 y5:

Imagen

Lo mismo me pasa con las demás imágenes ponga la ganancia a la mitad o menos o la exposición a 1/50. ¿Será que esta Toucam está escacharrada.....?. Gabriel me comenta que él toma los videos con estos valores y luego les resta el dark y ya veis que sus imágenes están limpias. Includo sin restarle el dark esto no le aparece de este modo.
GSO Deluxe 12" Dobson
Skywatcher 100ED
Montura Celestron CG-5 sin motorizar
Oculares Plössl Televue 25mm, Erfle 20mm Towa (T) e Intes-Micro 12mm
Binoviewer Baader Maxbright
Sky Safari 4 Plus en el smartphone

Avatar de Usuario
maxi
Mensajes: 1149
Registrado: 19 Ago 2005, 23:00
Ubicación: Barcelona
Contactar:

Mensajepor maxi » 15 Sep 2007, 11:29

Yo solo he encontrado una solucion para las malditas rayas, es capturar por encima de 20 FPS, de esa manera, por lo menos a mi me desparece, en un 95 %.


Saludos Maxi

Avatar de Usuario
gab9555
Mensajes: 560
Registrado: 29 Dic 2005, 00:00
Ubicación: ALMERIA
Contactar:

Mensajepor gab9555 » 15 Sep 2007, 11:53

mack, tienes activada la casilla de resta de bias en opciones , si no es asi activala ya que determinara el bias mediante el master dark , prueba distintos valores en bias , con esto deberias eliminar esas rayas.

saludos

Avatar de Usuario
hidra
Mensajes: 2363
Registrado: 14 Dic 2004, 00:00
Ubicación: Sant Celoni

Mensajepor hidra » 15 Sep 2007, 12:19

Jolines... pues vaya problema, no se si os pasa a todos o solo a tí Mack, a mi nunca me a dado el problema de las rallas.

Cuando le he subido la ganancia al maximo he tenido mucho ruido pero no rallas.

Yo tengo la Tou cam 740pro que teoricamente es exactamente igual que la spc900 a nivel de circuito y componentes electronicos. Que raro :-k

Habeis separado la placa que contiene el ccd de la placa principal?

Saludos :D

Avatar de Usuario
mack
Mensajes: 1299
Registrado: 12 Mar 2006, 00:00
Ubicación: Almería Levante
Contactar:

Mensajepor mack » 15 Sep 2007, 15:06

No, que yo sepa Hidra... :) . Mientras tanto sigo con mis pruebas. Ya he probado lo que dice Gabriel probando valores desde 1 hasta 100 (máximo) y la imagen no cambia ni un ápice. Me estoy dando cuenta de que a menor ganancia menor es ese efecto, pero claro si le damos poca ganancia el planeta no sale bien representado y por lo tanto infraexpuesto. Solución: cámara más sensible para que sin necesidad de tanta ganancia capte la misma luminosidad. Esto sólo tiene un nombre y se llama monocromo. Lo que pasa es que antes de irme a una Lumenera querría exprimir ésta al máximo
GSO Deluxe 12" Dobson
Skywatcher 100ED
Montura Celestron CG-5 sin motorizar
Oculares Plössl Televue 25mm, Erfle 20mm Towa (T) e Intes-Micro 12mm
Binoviewer Baader Maxbright
Sky Safari 4 Plus en el smartphone

Avatar de Usuario
mack
Mensajes: 1299
Registrado: 12 Mar 2006, 00:00
Ubicación: Almería Levante
Contactar:

Mensajepor mack » 15 Sep 2007, 20:14

Bueno, pues si alguien quiere una Toucam perfecta para hacer autoguiado con estrellas hasta la séptima magnitud y sólo algo de planetaria (mayormente lunar) que me lo diga, que le vendo la mía :D
GSO Deluxe 12" Dobson
Skywatcher 100ED
Montura Celestron CG-5 sin motorizar
Oculares Plössl Televue 25mm, Erfle 20mm Towa (T) e Intes-Micro 12mm
Binoviewer Baader Maxbright
Sky Safari 4 Plus en el smartphone

Avatar de Usuario
Verio
Mensajes: 2105
Registrado: 01 Nov 2006, 00:00
Ubicación: Madrid

Re: Resta de darkframe a Toucam

Mensajepor Verio » 15 Sep 2007, 21:19

mack escribió:Últimamente, como proceso del aprendizaje de la captura y procesado de imágenes planetarias, alentado por los consejos de Gab9555, me he propuesto aplicarle la resta de un masterdark también a los frames que componen un video, pese a su corta exposición, con el objeto de eliminar no ya su ruído térmico (despreciable para esta exposición) sino el bias y los hot pixels entre otras lindezas. Como bien sabemos el Registax ofrece esta posibilidad.

[...]
Lo mismo me pasa con las demás imágenes ponga la ganancia a la mitad o menos o la exposición a 1/50. ¿Será que esta Toucam está escacharrada.....?. Gabriel me comenta que él toma los videos con estos valores y luego les resta el dark y ya veis que sus imágenes están limpias. Includo sin restarle el dark esto no le aparece de este modo.


Yo tengo una SPC900. A mi las rayas solo me aparecen cuando subo la ganancia. Si la quieres utilizar para planetaria prueba a utilizar la ganancia mínima. Para el guiado las rayas casi no importan.

Tampoco utilices más de 5-10fps porque la Toucam tiene una implementación penosa del USB con un ancho de banda muy reducido. En cuanto subes los FPS la cámara empieza a comprimir las imágenes y se pierde definición.
LX200R 8" / MiniBorg 50
QSI540wsg / QHY5 / Lodestar / SVX-AO
Meade 26mm s.5000 / Baader 8-24 / ES-14mm / ES-20mm
http://www.astrobin.com/users/Verio/

Avatar de Usuario
mack
Mensajes: 1299
Registrado: 12 Mar 2006, 00:00
Ubicación: Almería Levante
Contactar:

Mensajepor mack » 15 Sep 2007, 21:44

Claro Verio, eso lo he comprobado, pero es que si no le subo la ganancia no hay manera de que el planeta salga nítido en la imagen. Sale demasiado infraexpuesto y marrón oscuro.
GSO Deluxe 12" Dobson
Skywatcher 100ED
Montura Celestron CG-5 sin motorizar
Oculares Plössl Televue 25mm, Erfle 20mm Towa (T) e Intes-Micro 12mm
Binoviewer Baader Maxbright
Sky Safari 4 Plus en el smartphone

Avatar de Usuario
mintaka
Moderador
Moderador
Mensajes: 5081
Registrado: 20 Dic 2004, 00:00
Ubicación: Fuenlabrada-Madrid
Contactar:

mintaka

Mensajepor mintaka » 16 Sep 2007, 09:02

Hola mack, ¿has probado a restarlo sólo de la imágen final?. Yo tengo la 740k y también sale con un patrón similar (a mí me salen líneas horizontales y suelo emplear 5 ó 10 fps). Yo lo atenúo un poco con un filtro de photoshop que destrama el ruido, pero se sigue notando. Ya nos contarás.

Saludos :D

Avatar de Usuario
Verio
Mensajes: 2105
Registrado: 01 Nov 2006, 00:00
Ubicación: Madrid

Mensajepor Verio » 16 Sep 2007, 09:32

mack escribió:Claro Verio, eso lo he comprobado, pero es que si no le subo la ganancia no hay manera de que el planeta salga nítido en la imagen. Sale demasiado infraexpuesto y marrón oscuro.

Supongo que será por el F15. Yo tengo también un 200mm pero F10. Júpiter me sale sobrado de brillo. De hecho con la ganancia al mínimo tengo que subir la velocidad de obturación para que no me salga saturado.

Yo creo que la mejor solución es ajustar el seguimiento y la posición de la cámara para que durante la toma del video el objeto se mueva despacio perpendicular a las rayas. El dark lo tienes que restar individualmente de cada cuadro. De esta forma un apilado estadístico (con sigma clipping o suma ponderada) debería eliminar la mayoría del efecto de las rayas.

De lo que se trata es que las rayas no estén siempre en el mismo sitio durante la toma. Una forma sencilla es utilizar velocidad de seguimiento lunar en vez de sidérea.
LX200R 8" / MiniBorg 50
QSI540wsg / QHY5 / Lodestar / SVX-AO
Meade 26mm s.5000 / Baader 8-24 / ES-14mm / ES-20mm
http://www.astrobin.com/users/Verio/

Volver a “Técnicas de Astrofotografía”